Compare the System requirements for Magento® 2 with the requirements of Magento 1 to check if your server meets the requirements for this new version of Magento®.

magento 2 system requirements

Before you can start with Magento® 2 of course you need to check your system compatibility. Below we've compared the Magento® 2 version with Magento® 2.0 to get a better sight on the different requirements so you know if Magento® 2 will run on the same server that you possibly run Magento® 1 on. The biggest difference with the requirements are the new PHP and MySQL version and the front-end difference, for example the new version of Magento® doesn't support the Microsoft Internet Explorer 8 and earlier but we're sure you don't going to mis that!

Supported Web-servers

Magento ®1
Apache 1.3.x
Apache 2.0.x
Apache 2.2.x
Magento®® 2
Apache 2.2 and better

 

 

MySQL

Magento®® 1
EE 1.13.0.0 and better: MySQL 5.0.2 and better
EE 1.12.0.2 and better: MySQL 4.1.20 and better
CE (all versions): MySQL 4.1.20 and better
Magento® 2
MySQL 5.6.x

 

 

PHP

Magento® 1
PHP 5.4 for EE 1.14 and better, CE 1.9 and better
Early CE and EE versions support PHP 5.2.13 - 5.3.24; or 5.4.x with special patches for CE and EE
Magento® 2
PHP 5.6.x
PHP 5.5.x

 

 

Required PHP extensions

Magento® 1
PDO_MySQL
simplexml
mcrypt
hash
GD
DOM
iconv
curl
SOAP
Safe_mode — off
Memory_limit 256Mb and more
Magento® 2
PDO/MySQL
mbstring
mcrypt
mhash
SimpleXML
curl
xsl
gd, ImageMagick 6.3.7 (or later) or both
SOAP
intl
Memory_limit 512Mb and more

 

 

Supported browsers

Magento® 1
Microsoft Internet Explorer 7 and better
Mozilla Firefox 3.5 and better
Apple Safari 5 and better (Mac OS)
Google Chrome 7 and better
Adobe Flash plugin is required
Magento® 2
Internet Explorer 9 and better(Windows)
Mozilla Firefox latest, latest-2
Google Chrome latest, latest-2
Apple Safari 5 and better (Mac OS)
Apple Safari Mobile for iPad, iPad Mini, iPad with Retina Display (iOS 6 and better)
Apple Safari Mobile for iPhone 4 and better; iOS 6 and better

 

 

Caching (optional)

Magento® 1
redis-server v2.6.9 and better
phpredis v2.2.2 and better
Magento® 2
Redisv 3.0
Varnish v3.5 or latest stable v4.x
Memcached latest version

 

 

Recommend

Magento® 1
Magento® 2
php_xdebug2.2.0 and better (for development purposes)
PHPUnit (as a command-line tool) 4.1 and better